Resolved
This incident has been resolved. All systems are 100% operational.
Investigating
We are currently investigating reports of slow load times and errors affecting Opuz
Between 10:00 and 11:00, the application experienced degraded performance characterised by increased response times and intermittent request failures. The issue was correlated with repeated StackExchange.Redis.RedisTimeoutException errors when accessing the Azure Redis cache.
Impact:
Elevated latency across multiple API endpoints
Intermittent failures for cache-dependent operations
Reduced overall application responsiveness for end users